Problem staying logged-in to RealJock

  • Posted by a hidden member.
    Log in to view his profile

    Apr 27, 2007 8:35 PM GMT
    Hi! Does anyone have any problems staying logged in to RealJock ? Every time I want to do something, it takes me back to the homepage and asks me to log-in again. I am using Firefox with Mac OSX. Any advice would be well received. Thanks! William
  • DrStorm

    Posts: 185

    Apr 28, 2007 2:06 AM GMT
    This happens to me too using the latest versions of FF/NS and windows XP. VERY annoying indeed.

    Does not seem to happen with IE, but then that wont help MAC users.

  • Posted by a hidden member.
    Log in to view his profile

    Apr 28, 2007 2:40 AM GMT
    I am also using FireFox on a Mac with OS 10.4.9. I have no problems. It sounds like you may have disabled RealJock's cookie. Go into the Preferences for FireFox and make sure that you have cookies enabled.

  • Posted by a hidden member.
    Log in to view his profile

    Apr 28, 2007 3:01 AM GMT

    I'm constantly bumped out too, also on Mac OSX and Firefox.
  • Posted by a hidden member.
    Log in to view his profile

    Apr 28, 2007 3:29 AM GMT
    IN FireFox...go to Preferences (Under FireFox at the upper left). Click on the tab labeled "Cookies". The box that says "Enable Cookies" should be checked.

    Again, I have FireFox on three computers...and none of them have bump me off RealJock problem.
  • Posted by a hidden member.
    Log in to view his profile

    Apr 28, 2007 3:40 AM GMT
    My cookies are enabled. Does sound like you are using an older version of Firefox, though, fastprof.
  • Posted by a hidden member.
    Log in to view his profile

    Apr 28, 2007 4:03 AM GMT
    Actually, Mr. Wish :-), it is a newer version. It is DeerPark 5.0.1 enabled for double processor G5s. The version for Pentium chip Macs is called Bon Echo....but both Bon Echo an DeerPark are new versions of FireFox.

    http://www.mozilla.org/projects/deerpark/alpha2.html
  • Posted by a hidden member.
    Log in to view his profile

    Apr 28, 2007 4:26 AM GMT
    Geez, I can't keep up. I just read about "Camino" recently.
  • Posted by a hidden member.
    Log in to view his profile

    Apr 28, 2007 1:15 PM GMT
    Hi guys,

    In an effort to track this down, I was hoping you could answer a question or two for me.

    First, are you getting kicked off very soon after you log in to the site, or is it after a long period of inactivity? Fastprof is correct about the cookie needing to be set for you to stay logged in. I'm trying to figure out if the cookie isn't getting set at all, or if your session is expiring after a period of inactivity.

    Second, are you guys using the "Remember Me" checkbox when you log in. That functionality also affects the cookie and I'm thinking we might have a bug there.

    Thanks for you help.

    Chris
    Developer
    RealJock.com
  • Posted by a hidden member.
    Log in to view his profile

    Apr 28, 2007 1:40 PM GMT
    It typically happens to me when I look at someone's profile. I click on a thumbnail and I am returned to the opening screen. I re-log on, go back to the profile and can view the thumbnail. I have the same experience with forum posts now and then. It seems unpredictable, doesn't always happen.
  • Posted by a hidden member.
    Log in to view his profile

    Apr 28, 2007 2:57 PM GMT
    I have the same problem and I am using the most current version of Firefox.
    Ric
  • Posted by a hidden member.
    Log in to view his profile

    Apr 28, 2007 3:05 PM GMT
    You know, I must apologize to Mr. Obscenewish. I thought you guys meant that when you are logged on, statically, you lose connection to the RealJock website. Now I see you mean that occasionally when you go to a profile and try to come "Home" you are sent back to the original login prompt.

    Yes, that's happened to me, very occasionally. It didn't seem remarkable enough to me, since I have the login information automatically saved, and all I have to do is click "login" without typing anything.

    So, yes, I have had that problem too, with Deer Park (FireFox).
  • Posted by a hidden member.
    Log in to view his profile

    Apr 28, 2007 3:46 PM GMT
    I use Firefox 2.0.0.3 and everything works just fine.
  • Posted by a hidden member.
    Log in to view his profile

    Apr 28, 2007 3:54 PM GMT
    So for those of you who are having this problem, it just happens out of the blue? Not immediately after you log in or after you've been away from your computer for a while? There's no pattern or consistency that you can see?

    Thanks again,

    Chris
    Developer
    RealJock.com
  • Posted by a hidden member.
    Log in to view his profile

    Apr 28, 2007 4:34 PM GMT
    For me, it happens immediately when I log on -- once I try and look at mail I am returned to the log on screen.

    The easy remedy for me is to close out the window and to re-open RealJock in a new window. Once I do that, I'm able to stay logged on.
  • Posted by a hidden member.
    Log in to view his profile

    Apr 29, 2007 5:07 PM GMT
    Thanks for the feedback. I'm going to try some different things in the next version which will hopefully make your sessions more reliable. That version will be released in the next week or two.

    Chris
    Developer
    RealJock.com
  • Posted by a hidden member.
    Log in to view his profile

    Apr 29, 2007 7:11 PM GMT
    Wow, now that's customer service! For the record I am using Firefox 1.5.0.11 with Mac OS 10.3.9 . "Remember Me" and cookies are enabled. The problem occurs when looking at profiles from the main page and with some forum posts, on a completely irregular basis. Thanks for your help!!
  • Posted by a hidden member.
    Log in to view his profile

    Apr 29, 2007 7:13 PM GMT
    What allgood said. Happens in IE7. Usually after I've had realjock open in multiple windows (not tabs). Regardless of whether I check the "remember me" box or not.
  • Posted by a hidden member.
    Log in to view his profile

    May 21, 2007 6:53 PM GMT
    Hi guys,

    I've made some changes to the session handling today and I was wondering if it's improving your experience with the site at all? Is everyone still getting kicked out? The changes went live a couple of hours ago.

    If things are still bad, I have a number of other things I'll try but I just wanted to see if this made any difference.

    Chris
    Developer
    RealJock.com
  • OptimusMatt

    Posts: 1124

    May 21, 2007 7:15 PM GMT
    hahahahaha

    So after the updated version went live a couple of days ago I stopped having this problem - lol, today, after just about everything I've tried to do on this site it has asked me to log back in.
    O.o BAD CHANGES

    lol
  • Posted by a hidden member.
    Log in to view his profile

    May 21, 2007 7:23 PM GMT
    BioMatty,

    Sorry for the headaches. Can you try deleting your cookies and see if that helps? You'll need to log in again afterwards. I'm not sure what browser you're using but if you let me know I'll give you instructions for deleting them.

    Thanks again,

    Chris
    Developer
    RealJock.com